Mimecast Degradation
Incident Report for Evolve IP
Resolved
Our engineers have completed monitoring and have confirmed that services have been restored. Accordingly, we have determined that this incident is resolved.
Posted Jun 08, 2023 - 08:47 EDT
Monitoring
[Monitoring]
We believe Mimecast has resolved the issue for email delivery delays on the US & US-B grids. Some customers may still see messages in their delivery queue with the error starting 'Duplicate Key...' these messages will gradually retry and process normally. We continue to monitor the situation and will post updates here.
Posted Jun 07, 2023 - 14:06 EDT
Identified
[Identified]
We have identified the issue related to email delivery delays for customers hosted on the US and US-B grids and impacted messages have been retried. Our investigation will continue, but we believe the issue will no longer occur, further updates will be posted here.
Posted Jun 07, 2023 - 11:53 EDT
Investigating
We are aware that some customers hosted in Mimecast US and US-B grids may be experiencing intermittent delivery delays and messages may be held in the processing queue. Mimecast is currently investigating the issue and updates will be posted as they become available.
Posted Jun 07, 2023 - 10:54 EDT
This incident affected: Third Party Cloud Services (<a href="https://community.mimecast.com/docs/DOC-1134#jive_content_id_North_America_Regio" target="_blank">Mimecast Email Security & Archival</a>).