iOS14 Release Notification
Incident Report for Evolve IP
Resolved
This incident has been resolved.
Posted Sep 28, 2020 - 11:48 EDT
Update
We have validated core functionality in iOS 14 for Evolve IP iOS applications (including UC-One and Clearlogin) as well as vendor applications (Citrix and VMware) that are used in our Workspaces and DaaS services. Given the critical nature of our applications in work-from-home environments, any major OS upgrade should be approached with caution to reduce potential drawbacks. In this case, given the unconventional nature of the release from Apple, we continue to advise our customers to delay upgrading until iOS 14 has stabilized over the coming weeks and most application developers have had a chance to further optimize their applications for this new OS.
Posted Sep 16, 2020 - 22:21 EDT
Update
We have confirmed that Apple's new operating system has become available in the US and we are in process of completing a full regression test on our current version. We strongly suggest that any user within your organization who uses Evolve IP applications on their iOS device not upgrade to iOS14 until we have confirmed compatibility. We will provide further notice and recommendations once we have completed.
Posted Sep 16, 2020 - 16:52 EDT
Monitoring
On 9/15 Apple announced that they were releasing iOS14 on 9/16 and provided less than 24 hours notice between the end of BETA and General release, which is not typical of a major release. Given historical iOS roll outs, we expect this to become available after 1pm EDT today. Our team is testing to confirm that all Evolve IP apps will function properly in iOS14, and in the interim we strongly suggest that any user within your organization who uses Evolve IP applications on their iOS device not upgrade to iOS14 until we have confirmed compatibility. We will provide notice once that has been confirmed. Thank you.
Posted Sep 16, 2020 - 12:05 EDT
This incident affected: UCaaS (Applications).