Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 10, 2024 - 01:01 EST
Scheduled
Dear Valued Client,
In order to continue to provide worldclass service and customer support, Evolve IP will be performing the following maintenance:
Start: 11/10/2024 1:00 AM EST End: 11/10/2024 3:00 PM EST Duration: 14h Purpose: Evolve IP will perform standard OS patching on the ECS platform. Impact: Customers may experience a brief outage when services are failed over in ECS. Required user actions: None
If you have any questions, please visit the Help Center portal at https://help.evolveip.net and submit a General Inquiry.
If you have an urgent incident, please call the Evolve IP Help Center at 877.459.4347, Option 2. Thank you for your attention and understanding.
Posted Sep 13, 2024 - 13:10 EDT
This scheduled maintenance affected: Evolve IP Help Center.