ECS v. 5.2.5 Reporting "Phantom Calls" in queue
Incident Report for Evolve IP
Resolved
This incident has been resolved.
Posted Jun 03, 2020 - 17:43 EDT
Update
Monitoring continues to yield positive results and will continuing monitoring for an additional day.
Posted Jun 02, 2020 - 17:15 EDT
Monitoring
The ECS Hotfix was successfully applied and we will continue to monitor.
Posted Jun 01, 2020 - 10:03 EDT
Update
We have received very limited reports of 'phantom calls' occurring for approximately 0.5% of the calls received. These interactions are largely cosmetic since the actual callers are answered by an agent.

Our Development team has completed coding and regression testing of a Hotfix for the 'phantom call' issue. The Hotfix will be applied on Monday, June 1st from 1:00 AM - 2:00 AM EDT and there will be a few minutes of downtime during this period.

For more detailed information, please refer to this KB page

https://support.evolveip.net/display/EIQ/ECS+Phantom+Call+Sta
Posted May 31, 2020 - 10:20 EDT
Investigating
We have received very limited reports of 'phantom calls' occurring for approximately 0.5% of the calls received. These interactions are largely cosmetic since the actual callers are answered by an agent.

Phantom Call is defined as an interaction that appears to Agents and Supervisors as a real call and is actually an “orphaned” interaction without a caller on the other end. These calls cannot be answered and appear in the Supervisor real-time metrics as a waiting call. Customers are advised that this is an orphaned "VISUAL" indication and it does not mean that a customer is stuck awaiting interaction.

Evolve IP's Engineering and Software Development teams are actively addressing these reports and will respond with a Hotfix in the coming days.

For more detailed information, please refer to this KB page
https://support.evolveip.net/display/EIQ/ECS+Phantom+Call+Status
Posted May 28, 2020 - 16:46 EDT
Update
The ECS Hotfixes were successfully applied and we will continue to monitor.
Posted May 27, 2020 - 08:01 EDT
Update
Our Development team has completed coding and regression testing Hotfixes for the sporadic reports of 'stuck calls'.

The Hotfixes will be installed tonight at 12:45am EDT and there will be a few minutes of downtime during the upgrade.

The following Hotfixes are included in this release:
-A “stuck call” is created when a warm / consulted transfer to a BP is completed normally.
-A “stuck call” is created when a warm / consulted transfer to a BP is completed to an Agent that doesn’t answer the interaction and the No Answer timeout doesn’t take effect.
-A “stuck call” is created when a warm / consulted transfer to a BP is completed to an Agent while that interaction is being Offered to the Agent.
-A “stuck call” is created when the routing engine doesn’t properly close the Interaction Handling Flow activities associated with that call.
-An Agent is not automatically placed in the No Answer state when they don’t answer a warm / consulted transfer via a BP.
-The Waiting Interaction counters in Supervisor becomes stuck and no call is displayed in the Current Interactions tab
Posted May 26, 2020 - 16:18 EDT
Update
Our Development team has continued to work the weekend and holiday to code Hotfixes for the sporadic reports of 'stuck calls'. We anticipate final coding and regression testing to be completed within 24-36 hours. On Tuesday, we will provide an expected date/time when these Hotfixes will be released to our clients.

In the meantime, our clients are advised to take the following steps:

1. Please ask your agents to not perform consulted / warm transfers to a Business Process (BP). Instead they should only perform a blind transfer to a BP.

2. Please remind your agents that are using a physical handset to either answer the call on the Handset OR on the Agent application.”
Posted May 25, 2020 - 11:05 EDT
Update
We have had sporadic reports of ‘stuck calls’ defined as an interaction that appears to Agents and Supervisors as a real call and is actually an “orphaned” interaction without a caller on the other end. These calls cannot be answered and appear in the Supervisor real-time metrics as a waiting call.

We have assessed and determined the cause and are actively developing a hot fix. Customers are advised to do the following:

1. Please do not perform warm transfers to a BP.

a. Instead, only perform blind transfers to a BP.

2. Please remind your agents that are using a physical handset to either answer an incoming call via the handset OR via the Agent application.

a. Please ask them to avoid answering the same call on both the handset and
the Agent application.

Development is actively working on a Hotfix and we will provide a detailed timeline once the Hotfix is in testing.
Posted May 24, 2020 - 14:43 EDT
Update
Our Engineering teams have identified two areas in error logs and below is the recommended guidance:

1. Please do not perform warm transfers to a BP.

a. Instead, only perform blind transfers to a BP.

2. Please remind your agents that are using a physical handset to either answer an
incoming call via the handset OR via the Agent application.

a. Please ask them to avoid answering the same call on both the handset and
the Agent application.

Development is actively working on a Hotfix and we will provide a detailed timeline once the Hotfix is in testing.
Posted May 24, 2020 - 09:51 EDT
Update
There are sporadic reports of stuck calls being investigated. As a reminder to the Unified ECS clients, only the Remote Office and Anywhere capabilities of the BroadWorks PBX/UC solution should be utilized to send ECS calls to an alternative destination (such as the Agent's mobile phone). We will provide an additional update once our Engineering teams complete their review of the stuck call examples."
Posted May 22, 2020 - 11:29 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 21, 2020 - 08:18 EDT
Update
Update:
In order to provide you with the best service possible, we plan to deploy several hotfixes to your Evolve Contact Suite (ECS) environment. These hotfixes address an issue encountered by a few Unified clients that resulted in calls “stuck” in the queue.

When: Thursday, May 21st from 1:30 AM – 2:00 AM EDT
Impact: All ECS applications will experience a few minutes of downtime during this period
Posted May 20, 2020 - 12:37 EDT
Update
In order to provide you with the best service possible, we plan to deploy several hotfixes to your Evolve Contact Suite (ECS) environment. These hotfixes address an issue encountered by a few Unified clients that resulted in calls “stuck” in the queue.

When: Thursday, May 21st from 1:30 AM – 2:00 AM EDT
Impact: All ECS applications will experience a few minutes of downtime during this period
Posted May 20, 2020 - 12:36 EDT
Identified
We’ve received a few reports from Unified clients that encountered a “stuck call”. A “stuck call” is an interaction that appears to Agents and Supervisors as a real call and is actually an “orphaned” interaction without a caller on the other end. These calls cannot be answered and appear in the Supervisor real-time metrics as a waiting call.

Update:
In order to provide you with the best service possible, we plan to deploy several hotfixes to your Evolve Contact Suite (ECS) environment. These hotfixes address an issue encountered by a few Unified clients that resulted in calls “stuck” in the queue.

When: Thursday, May 21st from 1:30 AM – 2:00 AM EDT
Impact: All ECS applications will experience a few minutes of downtime during this period
Posted May 19, 2020 - 12:52 EDT
This incident affected: UCaaS (Applications).