Odin Portal Inaccessible
Incident Report for Evolve IP
Resolved
Services have continued to function normally and this incident is being marked resolved.
Posted Apr 11, 2021 - 12:52 EDT
Monitoring
Our Engineers have addressed the incident and services have been restored. We are currently monitoring.
Posted Apr 10, 2021 - 11:15 EDT
Identified
Our Engineers have identified the cause of the incident and are currently implementing a solution. Additional information will be provided as it becomes available.
Posted Apr 10, 2021 - 10:04 EDT
Investigating
Our Engineers are actively engaged and investigating the incident and additional information will be provided as it becomes available.
Posted Apr 10, 2021 - 09:44 EDT
This incident affected: UCaaS (Applications).