Mimecast Service
Incident Report for Evolve IP
Resolved
Mimecast has confirm that all services are functioning normally for all customers.
Posted Oct 15, 2019 - 13:01 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 15, 2019 - 12:24 EDT
Monitoring
Mimecast has taken steps to mitigate intermittent access to the Administration Console and email processing delays for the US grid. They have observed an improvement in message processing and web security services over the last 30 minutes. They will continue to monitor closely and will provide an updates via their Mimecaster Central as updates are available.
Posted Oct 15, 2019 - 12:23 EDT
Investigating
Mimecast is aware that some customers on the US grid may be experiencing the inability to access the Administration Console and email processing delays. Web security clients may also be affected. They are working on resolving the issue and will provide updates on Mimecaster Central as updates are available.
Posted Oct 15, 2019 - 11:46 EDT
This incident affected: Third Party Cloud Services (<a href="https://community.mimecast.com/docs/DOC-1134#jive_content_id_North_America_Regio" target="_blank">Mimecast Email Security & Archival</a>).