Mimecast Service
Incident Report for Evolve IP
Resolved
We have sent an email to all Mimecast clients providing additional information regarding the recent Mimecast Directory Connector notification published in the administrative portal. Please review the email to help answer any questions you may have.
Posted Feb 10, 2020 - 18:08 EST
Monitoring
Mimecast has recently published a notification in their online administrative portal regarding a Microsoft security update that will automatically configure Active Directory Servers to require channel binding and Lightweight Directory Access Protocol (LDAP) signing by default.

If you have seen this message in the Mimecast portal, Mimecast has identified your account is currently configured with an unsigned Directory Connector. As such, if this security update is applied to your server(s) you may experience disruption to your Directory Connector.

Evolve IP will be sending an email communication no later than February 10th to the affected clients with information regarding your options. We strongly recommend reviewing this forthcoming communication before attempting any configuration changes as it may impact your service.
Posted Feb 05, 2020 - 08:43 EST
This incident affected: Third Party Cloud Services (<a href="https://community.mimecast.com/docs/DOC-1134#jive_content_id_North_America_Regio" target="_blank">Mimecast Email Security & Archival</a>).