Unable To Complete Calls/Fast Busy Issues
Incident Report for Evolve IP
Resolved
This incident has been resolved.
Posted May 21, 2020 - 14:34 EDT
Update
We are continuing to monitor for any further issues.
Posted May 20, 2020 - 22:00 EDT
Monitoring
Our engineers have addressed the issue with the underlying carriers, and services have been restored to their normal operations. We are currently monitoring for any further abnormalities.
Posted May 20, 2020 - 18:03 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 20, 2020 - 16:53 EDT
Investigating
Our engineers are actively engaged and investigating the issue with the underlying carriers, and additional information will be provided as it becomes available.
Posted May 20, 2020 - 15:51 EDT
This incident affected: UCaaS (Telephony).