Mimecast Outage
Incident Report for Evolve IP
Postmortem

Mimecast reported all services are processing.

https://status.mimecast.com/pages/5d849b1c02e65b3ec45369d4

Posted Jul 15, 2020 - 10:59 EDT

Resolved
Mimecast outage was resolved.
Posted Jul 15, 2020 - 10:57 EDT
Update
We are continuing to monitor for any further issues.
Posted Jul 15, 2020 - 07:07 EDT
Monitoring
Degraded Performance

Service - Email processing.

Mimecast administrative and user applications are stable and accessible to customers. We can now confirm that queue performance has returned to normal. We still continue to monitor and will provide an update in the next two hours
Posted Jul 15, 2020 - 07:04 EDT
Update
We are continuing to investigate this issue.
Posted Jul 14, 2020 - 16:49 EDT
Investigating
We are currently investigating:

Services affected: Email Processing, Administration Console, Web Security, Awareness Training, URL Protect, User Applications, Search
Posted Jul 14, 2020 - 16:01 EDT