Help Center Ticket Submission
Incident Report for Evolve IP
Resolved
Ticket creation and updates have normalized in the help center. This issue is being closed as resolved.
Posted Jun 08, 2023 - 10:15 EDT
Investigating
Evolve IP is researching reports of an issue with opening or updating tickets in our help center. To submit new tickets or get a status update, please reach out to your Support Pod by phone as we work through this issue.
Posted Jun 08, 2023 - 08:45 EDT
This incident affected: Evolve IP Help Center (Service Desk Portal).